What's new

8th Gen Air Con problems

Yaz7005

New Member
Messages
5
Reaction score
0
Car
8th Gen Accord 2.2D
Hi,

New member, first post so apologies if this is in the wrong place - it was so I moved it to here !

A/C on my 8th Gen iDtec is not working, gas is fine checked and held vacuum and was refilled, clutch not pulling in on compressor, no power getting to the compressor via the single red/yel cable, relays checked and swapped around to confirm operation, fuses in engine bay and under dash all good.

I suspect clutch as seized as the car is not used for periods of 6-8 weeks so I intend popping it of and seeing if its all free, access looks reasonable via R/H wheel arch.

Also need to check pressure switch and I understand from reading Freddofrogs posts there is an in built diagnostic on this car, (via OBD ?) an anyone advise on how this can be accessed please and if theres a list of the fault codes to.

Any other guidance gratefully received as apart from this its a cracking car !

Thanks.
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,135
Reaction score
582
Location
Halifax
Car
2009 Accord IDTEC
Try putting a 12v supply to the compressor directly and see if the clutch actuates, that’s the easiest way to test your compressor clutch.

I had the same issue on my 8th gen and it was the compressor. We replaced the clutch first and it was a waste of money as the compressor was seized internally. I managed to source a used compressor eventually but they’re quite pricey even used on these cars so do your checks first.

the pressure switch is under the front driver side corner of the bumper, you can access it without removing the bumper.
 

Yaz7005

New Member
Messages
5
Reaction score
0
Car
8th Gen Accord 2.2D
Thanks for the info, the clutch was seized, freed it off, clean and lubed it up but still nothing even with a direct feed to it so ***ume the coil is dead within, also I still have no 12v feed to the compressor so I will look at the pressure switch tomorrow and bridge this and see it this is the culprit for that part of the problem.

Appreciate the heads up on the located - saves taking the bumper off !

:)
 

dozi

New Member
Messages
11
Reaction score
1
Location
Sheffield
Car
Tourer 2010
Thanks for the info, the clutch was seized, freed it off, clean and lubed it up but still nothing even with a direct feed to it so ***ume the coil is dead within, also I still have no 12v feed to the compressor so I will look at the pressure switch tomorrow and bridge this and see it this is the culprit for that part of the problem.

Appreciate the heads up on the located - saves taking the bumper off !

:)
I had mine seize the other month. So much so that the car wouldn't turn over. Tried bumping the car and it snapped the serpentine belt. I have all the kit so i evacuated the air con with a new pump. Filled it up and new belt all sorted. Who would have thought eh!!
 

Yaz7005

New Member
Messages
5
Reaction score
0
Car
8th Gen Accord 2.2D
Hi Dozi,

Out of interest is yours the iDtec with the Denso compressor...? if so did you find a decent source for a new pump..?

Thanks
 

dozi

New Member
Messages
11
Reaction score
1
Location
Sheffield
Car
Tourer 2010
Hi Dozi,

Out of interest is yours the iDtec with the Denso compressor...? if so did you find a decent source for a new pump..?

Thanks
Yes i bought a used one off the bay for 40 pounds back in nov. Done 12000 miles with it so far.


That type
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,135
Reaction score
582
Location
Halifax
Car
2009 Accord IDTEC
Wow you did well for £40!!
 
Top