What's new

Euro-R Premium Navi - Headunit has built in Amp?

Andy MacRae

New Member
Messages
9
Reaction score
2
Location
Perthshire
Car
Accord Euro R CL7 03
I took the dash apart on my Euro R which comes with the Premium Sat Nav Japanese Head unit (39050-SEA-9410-M1) as opposed to the UK one which is usually 39050-SEA-E450-M1 (or sometimes labelled as 39050-SEA-E810-M1)

It also has 8 speakers as per UK Premium cars (4 x door, 2 x Tweeter and 2 x 6 by 9s in the shelf)

The thing is I cant find a separate Amp anywhere behind the stereo (I have removed everything from the top display to the gearstick so I have full access).
Also the Part number sticker on the top has speaker ohm rating symbols (4ohm/8ohm) which are not present on any of the Premium Navi HeadUnits that use the Amp.

The UK Navi Units only the 12v and Negative Earth symbols where the Japanese one has these + the ohm rating for speakers.

I am ***uming if there is no separate amp then either the headunit is doing the crossing or there are separate crossovers (or cheap capacitor setups) in the speakers.
Anyone have any knowledge of internal amp'ed Premium Navi systems?

IMG_4953 (Large) (Custom).jpg

IMG_4951 (Large) (Custom).jpg

IMG_4969 (Large) (Custom).jpg

IMG_4955 (Large) (Custom).jpg
 
Last edited:

Andy MacRae

New Member
Messages
9
Reaction score
2
Location
Perthshire
Car
Accord Euro R CL7 03
Some other pics for reference including the headunit plug with wire colours. I was expecting this 24pin plug to go to a 20pin input of the Honda Amp

IMG_4960 (Custom).jpg

IMG_4961 (Custom).jpg

IMG_4887 (Custom) (Custom).jpg
 

Andy MacRae

New Member
Messages
9
Reaction score
2
Location
Perthshire
Car
Accord Euro R CL7 03
Can confirm my Accord has a Navi Unit with an inbuilt Amp, plugged in my new Sony and all 8 speakers work fine with the right frequencies (bass only on the rears, midrange in the doors and highs in the tweeters.) I ***ume it has some stock crossovers or capacitors in the internal wiring.
 
Top