What's new

Knocking when starting and stopping engine

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
Hi all. I get about 5 knocks in quick succession when starting and stopping the engine.

Any ideas what the problem is please?

I've read around and I've read it could be the oil. It is due for a change next month so I will do that next week.
 

JapCar

Members
Messages
133
Reaction score
16
Location
Bristol UK
Car
Accord i-VTEC 2.0 EX
Economic said:
Hi all. I get about 5 knocks in quick succession when starting and stopping the engine.

Any ideas what the problem is please?

I've read around and I've read it could be the oil. It is due for a change next month so I will do that next week.
Oil...never read about it for knocking. Most probably would be engine mounts.
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
JapCar said:
Oil...never read about it for knocking. Most probably would be engine mounts.
Thanks for your reply. Is it something I can change with a ratchet on the roadside or would I have to take it to a mechanic?
 

csak1981

Members
Messages
65
Reaction score
11
Location
Scotland
Car
Accord Tourer 8th Ge
When was it last serviced? If it's been a while then a new air filter fuel filter and oil and filter changed is worth doing might save you spending unnecessary on new mounts if it sorts it
 

csak1981

Members
Messages
65
Reaction score
11
Location
Scotland
Car
Accord Tourer 8th Ge
Just noticed you mentioned oil needing changed next month but i would do air filter as well. Engine might not be getting enough air if slightly clogged. Ecu might be compensating during normal running but causing not a 100% optimal start up and shut down
 

JapCar

Members
Messages
133
Reaction score
16
Location
Bristol UK
Car
Accord i-VTEC 2.0 EX
Economic said:
Thanks for your reply. Is it something I can change with a ratchet on the roadside or would I have to take it to a mechanic?
Probably not all engine mountings change are roadside job, but it's good first make sure which one (or if) needs to be changed which is mechanic job.
 

JapCar

Members
Messages
133
Reaction score
16
Location
Bristol UK
Car
Accord i-VTEC 2.0 EX
csak1981 said:
Just noticed you mentioned oil needing changed next month but i would do air filter as well. Engine might not be getting enough air if slightly clogged. Ecu might be compensating during normal running but causing not a 100% optimal start up and shut down
I don't support similar theory...and it is easy to check it by start/stop engine without filter at all...
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
csak1981 said:
When was it last serviced? If it's been a while then a new air filter fuel filter and oil and filter changed is worth doing might save you spending unnecessary on new mounts if it sorts it
I changed the oil and filter Feb last year.

I changed the fuel filter about a year ago.

I changed the pollen and air filters about 6 months ago.

I have been getting Intermittent engine light warnings but they always went away within 24 hours. I got it looked into about 18 months ago and the mechanic said it was something to do with air but we were busy diagnosing something else (suspension) and we never got round to isolating the issue.

Does that ***ist further?

Thanks all
 

csak1981

Members
Messages
65
Reaction score
11
Location
Scotland
Car
Accord Tourer 8th Ge
JapCar said:
I don't support similar theory...and it is easy to check it by start/stop engine without filter at all...
Good call never thought of that. I would try this first before tackling mounts.
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
csak1981 said:
Good call never thought of that. I would try this first before tackling mounts.
So I should take the air filter in the engine out and start the car and report back? What should I expect? What's good and what's bad?
 

csak1981

Members
Messages
65
Reaction score
11
Location
Scotland
Car
Accord Tourer 8th Ge
Open airbox and remove filter then fasten airbox up. See if the knocks are still present when starting and shutting off.

If gone - problem solved get a new filter. If knocking still present - put filter back in and get mounts checked by mechanic before replacement as they ain't the cheapest of parts for what they are.

When was the last time you had a warning light as you were saying on the dash? If you had any recently the codes might still be stored and you can get them diagnosed.

It might be related
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
Thank you. I'll do this tomorrow morning.

Last time I got the light was about 3 weeks ago.
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
Channel Hopper said:
Where in London are you ?
Shepherd's Bush, and Harrow, West to North West.

Thanks.

I haven't got round to trying the air filter test yet, just been busy. Planning on doing it today.
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
saj said:
If you can get to enfield i will take a look at it for you. Pm me.
It says you can't receive any more messages haha.


Thanks so much for your offer, when is best for you? I can do today after 6pm, tomorrow after 9pm, saturday after 6pm, anytime on Sunday, or any time after 3pm next week.

Thanks again!
 

Economic

Members
Messages
124
Reaction score
12
Location
London
Car
54 plate 2.2 CTDI ex
Channel Hopper said:
Keep us informed on progress.
Ok well I opened the bonnet and realised that the tools I had in my garage were too big, so I closed the bonnet and went to the flat to get smaller sockets. However, when I got home, I didn't hear the knocking. I started the engine again in case my eyes were deceiving me, and no, the sound did not appear.

As soon as the knocking went I noticed that the biting of point my clutch is now very very low, to the point where 5% of the time the clutch will not let me get into gear.

I'm not sure if the two are related.

Anyway, I'm planning on meeting Saj tonight and I'll update tonight.

Thanks all.

Edit: we weren't able to meet today, we'll rearrange.

I'm still surprised that the knocking has gone.
 

NightHawkAccord

New Member
Messages
3
Reaction score
1
Car
CL9 2.2 Exec
Hi all. I get about 5 knocks in quick succession when starting and stopping the engine.

Any ideas what the problem is please?

I've read around and I've read it could be the oil. It is due for a change next month so I will do that next week.
I have a little rattle too. Looks like the Gearbox mount at the moment. Will check it next time it's up on a ramp!
 

Channel Hopper

Members
Messages
1,065
Reaction score
149
Location
KT8 Postcode
Car
Accord 7 Estate 2005
Mine starts with a rattle , more often when warm than cold though (short runs to the local town). The only failure picked up in the MOT last year was an engine mount up front and changing that did not improve anything despite me knowing it could have led to something more serious once pointed out.

I posted in a thread (unless I started it) where the fuelling in warm/hot weather stops the car from running until the engine bay has cooled down. I used to spend time shopping or just walk home when it happened, to save cranking the engine fruitlessly, flatten the battery and have to drag another one out of the garage in a rucksack, a real sod on a bicycle.

The car has always started from cold regardless of battery type or condition, if that helps nail down the specific issue you have.
 

mlkehunt

Members
Messages
50
Reaction score
15
Location
Norway
Car
08 I-CTDI sport
any chance it could be loose exhaust bits not dampened properly knocking into the subframe, underbody or reinforcements? the subframe is unlikely since the flex pipe is below the cat but who knows
just done an exhaust job on an old hilux pickup, and I noticed the pipes knocking into the frame in 3 different spots before oxy-acetylene adjustment of the damper mounts, you could hear it clear as anything on startup and shutdown but it was unnoticeable during idle
 

Bad Dog

New Member
Messages
9
Reaction score
0
Car
Accord 2.2.CDTI
It's a Manual, Diesel 07MY
Have you checked the heat shielding on your cat ? I had a similar rattle. Turns out the heat shield mounting bolt Holes had rusted out, the bolts eerie still in place but the shield was loose. Solution large jubilee clip (about 6 inch diameter) placed around the entire cat and tightened up ......no more rattle. Might be worth a look cheap fix
 
Top