What's new

O2 Sensor

Mrbuzz

Members
Messages
4
Reaction score
0
Location
Woking
Car
Accord
Hi all. Just bought myself a "get out of trouble" accord a month ago as my Renault was going to cost too much to fix. I only paid £550 for the honda and I quite like it but I am having some problems.

It's a V plate 20l vtec se with 97000 miles on the clock. The problem I have is basically it has no oomph! Ticks over nice and quietly but is quite jerky when on the move unless very gentle with the throttle and if I put my foot down I go nowhere fast!

The engine management light is on and the guy I bought it from said that his code reader said something about the cat emissions but I'm afraid I don't know the error code.

Spoke to our work diesel fitter and he said it sounded to him like the lambda sensor had gone and I then searched the net and everything I found seemed to agree with him.

Looked through the service history when I got home and found that the front "upstream" sensor had been replaced 18 months ago.

So while I wait for my own code reader to be delivered I wondered if anybody had any other ideas as to what my be the problem?

Any help would be appreciated as I really don't know much about these cars.

Many thanks.

Alan
 

Salim

TAF Member
Messages
1,835
Reaction score
47
Location
SW
Car
Accord
Most likely is lambda sensor, though not sure it will be the only cause. I would wait till you get your code reader. Read and note them then reset go for a drive and see which ones come back.
 

Mrbuzz

Members
Messages
4
Reaction score
0
Location
Woking
Car
Accord
Most likely is lambda sensor, though not sure it will be the only cause. I would wait till you get your code reader. Read and note them then reset go for a drive and see which ones come back.
Thanks. Seems a bit strange that it would fail after only being replaced 18 months ago. I did read somewhere that it's best to replace the one on the cat at the same time because they don't always play nice if you only replace one.
 

Salim

TAF Member
Messages
1,835
Reaction score
47
Location
SW
Car
Accord
It's had the bank 1 pre cat sensor replaced maybe its the one after the cat needs doing now? You can change both but if the other is tested to be reading correct why bother. I'm presuming you only have two , not familiar with your car.
 

Mrbuzz

Members
Messages
4
Reaction score
0
Location
Woking
Car
Accord
It's had the bank 1 pre cat sensor replaced maybe its the one after the cat needs doing now? You can change both but if the other is tested to be reading correct why bother. I'm presuming you only have two , not familiar with your car.
Thanks again. I guess I'll have to wait and read the codes.
 

adrenalinas

Members
Messages
274
Reaction score
4
Location
Lithuania
Car
accord iES CG9
usuallyboth sensor go bad. I have changed my upstream O2 sensor and 2 weeks later I got to replace secondary sensor because of catalyst error.
If you will get "P0420 Catalyst system efficiency below threshold" first fing to change is secondary sensor
 

Mrbuzz

Members
Messages
4
Reaction score
0
Location
Woking
Car
Accord
usuallyboth sensor go bad. I have changed my upstream O2 sensor and 2 weeks later I got to replace secondary sensor because of catalyst error.
If you will get "P0420 Catalyst system efficiency below threshold" first fing to change is secondary sensor
Thank you. I'll get the reader soon and find out. Thanks for your help.
 

peteraccord

Members
Messages
34
Reaction score
4
Location
Warrington
Car
2004 Honda Accord
Have you done it? I have the same now aswell. I read It is working with the original one, I mean the Denso sensor. It won't work with other type of sensors... I tried it. Bank 1 Circuit 1 is always before the cat. Some mechanic says Its in the cat, but many posts and a guy from Honda says its before the cat sensor. Not cheap...Sadly...
 

peteraccord

Members
Messages
34
Reaction score
4
Location
Warrington
Car
2004 Honda Accord
Thanks for the idea! Now I have the factory one from Denso but if the evil light is stil come up I check the other one and by a second hand one!!!
Thank you very much!
 

exec

Members
Messages
1,703
Reaction score
126
Location
London
Car
'99 2.0 SE Exec
Yeh you are right the 02 sensor only works with OEM one, or as some members reported NGK NTK one is compatible, although I have no personal experience of this. The part is around £150 from Honda, pricey, but if you wanna keep your car long term then worth it.
 
Top