What's new

Replacing the Glow Plug Controller Relay

Zim

New Member
Messages
4
Reaction score
1
Car
Accord CDTI 2.2 Esta
Hi all, I've been having trouble with 2004 2.2 Tourer and have replaced the glow plugs but still have the P1384 error. I have obtained a replacement relay but I wanted to make sure that I followed the correct procedure for installing it. In particular I wanted to see if with the ignition off I can simply unplug the old one and install the new one or do I need to disconnect the battery or other leads? Thanks in advance for your help and advice.
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,035
Reaction score
560
Location
Halifax
Car
2009 Accord IDTEC
Hi the issue isn’t your relay but one of your glow plugs, likely a hairline crack in one of them and not always visible. Avoid aftermarket glow plugs, the ecu is sensitive to the quality and expects a certain millisecond response time which substandard plugs often can’t meet and end up triggering spurious errors.
 

Zim

New Member
Messages
4
Reaction score
1
Car
Accord CDTI 2.2 Esta
Thanks for the information, I appreciate your time. I've replaced the glow plugs with Honda ones (one was definitely duff) so that is why I've moved onto the controller. It looks like a simple unplug old controller and plug in the new but my experience is that things are often more involved than at first sight....
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,035
Reaction score
560
Location
Halifax
Car
2009 Accord IDTEC
Yes it is a straight swap of the relay for a new one.
 

Zim

New Member
Messages
4
Reaction score
1
Car
Accord CDTI 2.2 Esta
Thanks again F6HAD. I will give it a go and feed back on how I get on.
 

Zim

New Member
Messages
4
Reaction score
1
Car
Accord CDTI 2.2 Esta
Well as it turns out F6HAD was entirely correct. The glowplugs were not genuine Honda as I had thought but Bosche . Still good quality but just not right. New set of Honda genuine glowplugs and it's all working a treat. I thought I would report back for anyone else experiencing the problem - double check the glowplugs!!

Many thanks F6HAD
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,035
Reaction score
560
Location
Halifax
Car
2009 Accord IDTEC
Thanks for circling back mate. Glad you got it fixed.
 
Top