What's new

What went wrong

IrishGirl

New Member
Messages
3
Reaction score
0
Location
Ireland
Car
Accord 2.2 i-dtec
So i bought this car 2009 2.2 diesel 150bhp accord couple of months ago. 76k miles.

Anyway going to work this morning car was fine starting off. Then once i got on the motorway and accelerated i heard a pop and then she started pumping white smoke out the exhaust and the DPF clogged symbol came on before the CEL. Engine vibrating like mad and making a really bad constant clicking noise the higher the revs. Said id try drive to next exit to get off the motorway but she then died
So had to pull over. She'd start after that but i got a tow truck to bring her home as I didn't want to cause damage.

Now i drive nearly 40 mins twice a day on the motorway normally sitting on 80 miles the majority of the way and no dpf regeneration light came on.

Any guesses?

Any idea?


Sounds like this now



https://youtu.be/Vf4x_HL7jDE
 

IrishGirl

New Member
Messages
3
Reaction score
0
Location
Ireland
Car
Accord 2.2 i-dtec
edgeoftime said:
Sounds like an injector out of it's hole??
Have a mechanic coming tomorrow to look just wanted to know if it's bad or a rough idea what it is
 

Channel Hopper

Members
Messages
1,304
Reaction score
201
Location
KT8 Postcode
Car
Accord 7 Estate 2005
edgeoftime said:
Sounds like an injector out of it's hole??
That would require unscrewing, unless there was a serious fuel lock on that cylinder to take out the threads in the head.

Must be the copper washer/seal if it is anything like the iCTDI
 

IrishGirl

New Member
Messages
3
Reaction score
0
Location
Ireland
Car
Accord 2.2 i-dtec
Nothing looks out if place in the engine bay. Injectors look fine ie haven't popped out or anything. No pipes off or anything.

Just that really bad knocking noise in the video and plumes of white smoke out of the exhaust and there is a really strong smell of fuel.
 

apintofmild

Members
Messages
903
Reaction score
181
Location
Yorkshire
Car
Golf GTD
What did your mechanic say? Could it be a burnt / broken exhaust valve?
 

edgeoftime

Members
Messages
1,941
Reaction score
194
Location
Waltham Abbey Essex
Car
11 idtec tourer ex.
IrishGirl said:
Nothing looks out if place in the engine bay. Injectors look fine ie haven't popped out or anything. No pipes off or anything.

Just that really bad knocking noise in the video and plumes of white smoke out of the exhaust and there is a really strong smell of fuel.
Diesel knock, one of them is not working?? on old fashioned engines we crack the feed line and listen for drop in revs, whichever it is causes this is a suspect injector, no idea about these electronic gizmos though.
 

Sysek

New Member
Messages
7
Reaction score
0
Car
Accord MK7 2.2 CTDi
Hi Irish girl
Any resolution on your issue?
 
Top