What's new

2005 Accord 2.2 icdti strange heating problem

Cagliostro

New Member
Messages
2
Reaction score
0
Car
Accord 2.2 ictdi
Hello!! So, I'm haveing trouble with heating on my Accord.. when Ac is off and air is set to mix air inside the car, everything is fine, both sides blowing hot..but, if i Turn on Ac, drivers side starts to Blow cold, no matter what setting, passanger side blows as it should.. i was looking at drivers side mixing flap, looks allright, self diagnostics says that is allright as well..
I have changed Ac gas in the sistem as well..
What should i look next, any suggestions?
Thanks!!
 

Channel Hopper

Members
Messages
1,017
Reaction score
147
Location
KT8 Postcode
Car
Accord 7 Estate 2005
I have same, thouugh it is very rare I get hot air at all. I did 100 miles in a day last week and it was only about 10 miles before the return journey the heater started putting put some warm air.

The most annoying thing is the cold air that always ends up on the drivers footwell, I suspect there is an airlock in the matrix somewhere that I have yet to bleed out. Somebody mentioned a fix just over a month ago.
 

Cagliostro

New Member
Messages
2
Reaction score
0
Car
Accord 2.2 ictdi
I did coolant change over a year ago and everything was fine till month ago.. i do not thing that airlock is the case with my car..because heating is working fine if Ac is off and recirc is on.. in that case, both sides are blowing hot air.. but, as soon as I Turn off recirculation, drivers side starts to Blow cooler air than on the passanger side..and if i Turn on Ac, drivers side starts to Blow cold air no matter what setting controlls are set to..
I have took apart half od the dashboard, Will pull it out completly and see what is going on..
 
Top