What's new

Almost no boost till 2.5k rpms

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
Hello everyone!
Greetings from Lithuania :)
I have a mistery with my Accord 2004 2.2, maybe you all will help me to solve it because I don't know where else to look :D
Problem is that car has almost no boost from turbo till 2.5k revs when it really kicks in. In rare occasions I feel it kicking in earlier (especially in 3rd gear or when going uphill).
Things was done:
Replaced turbo - no difference.
Fuel filter (yes, correct one) - no difference.
Took it to local remapper:
EGR Off - Car got much better on low revs, much much smoother to drive, less fuel consumption, not struggling to accept the throttle anymore. After thst car basically was able to drive again.
Also he tested it on Dyno and told me that turbo only starting to boost at 2.5 and its full boost is on 3.5k rpms. It managed to squeeze the original HP without remaps, just egr off. He also told me that normally it should start to boost at a little bit more that 2k and reach full boost on 2.5k (showed me the graphs of the other hondas with same engine).
He diagnosed that a lot of problems should be in EVR valve.
So..
Things I did:
Replaced EVR - car got better, from this moment I sometimes feel boost earlier. Car lacks of power in second gear.
Replaced IMRC, few different ones, still don't understand if there is any difference in that (still trying to figure it out).
Tried replacing MAP and MAF, no difference (remap guy told me that were ok also).
Tried replacing air intake shuttle position sensor (dont know how it is called), because I had few laying around, no difference also.
Checks catalysts - all good.

So guys, I don't even know where to look at. The donor car I took turbo was driving excellent. Although it was facelift model (is there any turbo differences?).
Maybe you have some ideas or suggestions?
Also Worth to mention is that I have put six gear gearbox from facelift because I had to replace the clutch but had gearbox laying around so figured why not? Now it is much better on highways :)
Also worth to mentions is that car doesn't smoke, no blue, black, white smokes.
Waiting for your opinions guys, read a lot of threads here but still I am where I am.

Many thanks!!!
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
Yep, engine had new timing chain, all marks set correctly. Engine done about 320k kms
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,126
Reaction score
582
Location
Halifax
Car
2009 Accord IDTEC
Before replacing all these parts including the turbo, I would have started with diagnostics and functional checks of your hardware.

Is your egr physically blanked too? If not then I would advise doing this first as you may have a leak meaning egr gasses are still entering the intake.

the turbo you replaced, was it new or used?

finally have you run a leak back test on your injectors? I’ve seen this issue due to a bad injector previously.
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
Before replacing all these parts including the turbo, I would have started with diagnostics and functional checks of your hardware.

Is your egr physically blanked too? If not then I would advise doing this first as you may have a leak meaning egr gasses are still entering the intake.

the turbo you replaced, was it new or used?

finally have you run a leak back test on your injectors? I’ve seen this issue due to a bad injector previously.
Thanks for your answer!
Well I had some parts laying around from the donor car so tried to go that way.
Tried two different used turbos, both of them were taken from nice driving cars. The actuator of turbo seems to move freely, not sticking. All hoses also seems ok. Checked intercooler, also clean.
EGR is blanked on the point where it enters intake manifold, near the air shuttle.
Leak back was tested some time ago.

I am thinking that IMRC can be some kind of problem? Because I have few of them, used, and both of them act a little bit differently. Maybe I don't let them to spend some time for ecu to adjust (read that ecu needs to adapt new one???).
But car doesn't smoke, while I read that if imrc is faulty then car should smoke?
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,126
Reaction score
582
Location
Halifax
Car
2009 Accord IDTEC
You need to run some live logging with a decent diagnostic and check what your actual figures are vs target
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
Ok, so quick update.
The EGR blanking was the last step I did and I didn't reset the ECU after that.
After driving around I noticed that it was getting better and better. So I reset the ECU by removing the battery connection.
So after reset the car got even better. Now the turbo starts to pull at around 2.2k rpm and the car feels alive.
The only problem I noticed is that if I try to.. you know.. race it... push it in first gear, then in second, then in third, the car seems a little bit sluggish, like a lack of boost.
But when I am like cruising on 1.5k RPMs in 3 or 4 gear and push it, it pulls very well and everything seems as it should be.

I didn't try to do live logging yet, but I can see improvement now and the car seems to be ALMOST as it should be.
Also, I noticed a vibration when standing on idle which tickles hands on the steering wheel. Maybe it is an engine mount? Because it is gone when driving.

I am planning to do live logging and maybe F6HAD or someone else can tell me what should be my target figures?
Many thanks!
 

F6HAD

Affiliate / Co-Founder
Staff member
Messages
13,126
Reaction score
582
Location
Halifax
Car
2009 Accord IDTEC
The car is not tuned? Only egr is switched off? Are you sure? And your fuel filter has been replaced with a proper Honda unit? Have your injectors been tested?
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
The car is not tuned? Only egr is switched off? Are you sure? And your fuel filter has been replaced with a proper Honda unit? Have your injectors been tested?
Car has only egr off. Fuel filter replaced few weeks ago with genuine one Bosch. Injectors are not tested yet, will try to test the leak back soon.
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
Also maybe anyone knows if the turbo from pre-facelift is somehow different on a facelift?
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
Quick update.
The car sometimes started to boost correctly starting at around 2k rpms. Very nice.
But sometimes it don't...
Notice very strange behavior, maybe someone knows what that could mean.
When I press pedal fully to accelerate and there is no boost I quickly press pedal few times and it starts to boost as it should, very nice pull, like it should be.
Just like cruising and 2k, pressing pedal and no boost, then quick tap and it puuuulsss immediately.
Any ideas guys? Many thanks!!!
 

Channel Hopper

Members
Messages
1,093
Reaction score
157
Location
KT8 Postcode
Car
Accord 7 Estate 2005
It wouldn't harm to check the connections to the tps. ( or swop out if you have a replacement)

I had trouble two years ago which was down to the loom being very tight just in front of the fuel filter, the car would go into limp mode until I re-routed to leave some slack.
 

Ferarix

New Member
Messages
8
Reaction score
0
Location
Lithuania
Car
Accord 2004 2.2
It wouldn't harm to check the connections to the tps. ( or swop out if you have a replacement)

I had trouble two years ago which was down to the loom being very tight just in front of the fuel filter, the car would go into limp mode until I re-routed to leave some slack.
I replaced tps, no difference sadly :( Will try to check wiring
 
Top